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Virtualization 

 

1) Vmware Network Setup 

 

In order to set up our virtual machines, we must install Vmware and create a 
Virtual Network for our environment. 

We can reach it in: 

 

Edit → Virtual Network Editor 

 

Let’s choose VMnet10 and configure a Virtual Network: 

 

▪ Change Virtual Network name from VMnet10 to ActiveDirectory 
▪ Select “Host-Only” 
▪ Change the Subnet IP to: 

▪ Range: 192.168.126.0 
▪ Netmask: 255.255.255.0 (/24) 

▪ Uncheck the DHCP option 

 

 

 



 

We can schematize the network to make it clear: 

 

 

 

 

2) Windows Server 2022 Installation 

 

In order to install Windows Server 2022, we must have an ISO image. 

Select: 

 

File → New Virtual Machine → [Wizard] → Typical 

 

From there, in “Guest Operating System Installation” select: 

 

Installer disc image file (iso) → [Browse to the path of the ISO image] 

 

Since we install it for educational and training purpose, we won’t use a product 
key. 

 

Create a username and a password. 



The Operating System and its version are automatically detected. 

Skip the error message related to the product key. 

 

Name the machine Windows-Server-DC and choose an emplacement for the 
machine. Hit Next. 

 

Chose a size in the Disk for the machine (I use 60GB), and choose “Split VD into 
multiple files”. Hit Next. 

 

On the Hardware Details, NAT is chosen by default, and we want VMnet10.  

In order to change that select: 

 

Network Adapter → Custom → ActiveDirectory 

 

 

 

We’re going to click finish and shut down this virtual machine. 

 

 

 



Let us power on the virtual machine for the first time.  

Once the machine is turned on, press the install now button. 

 

 

 

Choose the Language, Time and keyboard format and press Next. 

 

 

 

We need to choose the Desktop experience because we want the actual desktop 
GUI, and not a Windows Server CLI. Press Next.  

 



 

 

Accept the license and press Next 

The next step purpose is to indicate if we want to upgrade an actual existing 
server (Upgrade). Since we have an empty disk, we want to choose Install. 

 

. 

 

The free disk partition is detected (We allocated 60GB). 



 

 

Click Next. 

 

 

 

We’ll let this run thought the installation process. 

 

 

 



Now we have to choose a password for our Administrator user. 

It is a very important step, since the password of the actual Administrator will be 
the password of our future Active Directory Domain Administrator. 

 

 

 

The next screen is the final one, and Congrats we installed our Windows Server. 

 

 



3) Windows 10 Installation 

 

The first step is to install the ISO image from the following link 

 

https://www.microsoft.com/en-us/software-download/windows10 

 

Install the virtual machine in Vmware: 

File → New Virtual machine → Next 

 

 

 

These steps look like the mentioned steps for the previous part. 

We will install the ISO image downloaded earlier: 

 

 

 

Since we are using it for educational purposes, we won’t use a key and use the 
free trial. 

https://www.microsoft.com/en-us/software-download/windows10


 

 

Choose a name for our Virtual Machine. I named it Windows10. 

 

 

 

For this machine we will allocate 60GB as well. 

Notice that it is better to split the disk into multiple files. 



 

 

We settled our machine to have 4GB of RAM and joined it to our VMnet10, 
ActiveDirectory. 

  

 

 

 



And let’s begin the installation. 

 

 

 

 

The new VM is installed and now we can start configuring the network setting. 

 

 

 

 

 

 

 

 

 

 

 

 

 



Windows Server Setup 

 

1) Network Configuration 

 

Our Windows Server machine is going to be an Active Directory Domain Controller 
later.  

But a domain controller is also a DNS server.  

When a machine is promoted to a DNS server, it’s IP is a reference for domain 
resolutions. For this reason, we must make sure that our IP is manually configured 
and not generated by a DHCP server.  

Indeed, if the IP of a Domain Controller is distributed by a DHCP server, a bad 
configuration could lead to an IP regeneration and the joined machine will struggle 
to find the Logon Server and the DNS server.  

 

WinKey + R → ncpa.cpl → Ethernet0 → Properties 

 

 

 



This interface is very important as it can help us to configure the network settings 
for our Windows Server machine.  

Notice that many vulnerabilities related to IPv6 exist, especially MITM6 or CVE-
2024-38063.  

For that reason, we will uncheck it since we won’t use IPv6 in our domain. 

Notice also that for security purposes, limiting unnecessary features and 
restricting authorizations can help avoid many exploitations.  

 

 

 

Next, let us set a static IP for our Windows Server machine. 

 

 

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2024-38063
https://msrc.microsoft.com/update-guide/vulnerability/CVE-2024-38063


Additionally, we added the preferred DNS server address to 127.0.0.1, since the 
server itself is running the service.  

The alternate DNS server 8.8.8.8 is the google DNS address. 

 

 

Active Directory Setup 

 

1) Basic Checks 

 

We mentioned it before, but please check again the following: 

 

▪ Check the DC IPv4 address to be manually configured 
▪ Check the Preferred DNS server to be 127.0.0.1 and the second is 8.8.8.8 
▪ In virtualized environment, make sure that the VMs are in the same 

network 

 

2) Domain Roles & Feature Installation 

 

Select Add roles and Features 

 

 

 

Now, the wizard will propose an installation type. Install a local server. 



 

 

We want to install it on the current server.  

 

 

 

Now come the interesting part. Select Active Directory Domain Services. 

 

 

 



We can confirm it. 

 

 

 

Onto the next section, let’s install our domain controller and our AD Server. 

 

3) Domain Controller Setup 

 

The domain controller is the main server in an Active Directory environment. 

As the Domain Administrator is the user authority, the Domain Controller is the 
computer authority.  

From our notifications, we can observe that we must configure the installed 
Active Directory Server. 

Select Promote this server to a domain controller in the notification. 

 

 

 



Select Add a new forest and choose your domain name (bentech.com) 

 

 

 

Don’t forget to add the DNS features at the following step 

 

 

 

Let the NETBIOS name as generated 

 

 



For the PATHS part, don’t touch anything except if you want your most important 
files to be stored in another location (not recommended). 

If everything is okay the prerequisite checks should indicate positive statements, 
press installation and the server should restart automatically. 

 

4) OU & Users 

 

Go to 

  

Tools → Users and Computers 

 

And check that your arborescence has been created 

 

 

 

Our domain is composed of objects: 

 

▪ Organizational Units (OU’s) 
▪ Users 
▪ Groups 
▪ Computers 
▪ Policies 
▪ Etc… 

 

In order to organize them, we can assign objects to OU’s (Documentation). 

To create an OU, right click the Forest name and select the following 

 

https://learn.microsoft.com/en-us/windows-server/identity/ad-ds/plan/creating-an-organizational-unit-design


New → Organizational Unit → Choose a name 

 

Under these OU’s, we can add objects as Users. 

For management purposes, a System Administrator can locate easily a user or a 
computer for management using good OU indexing. 

In order to create a user, right click the created OU and execute: 

 

New → User  

 

Configure the name and the logon name, which is the username for 
authentication. 

 

 

 

Next, select a password and make sure the user has to change it once logged in 
for the first time, by selecting User must change password at next logon. 

 

 



This is a security measure.  

 

 

5) Users Restrictions 

 

We will create 2 limitations for our users 

 

▪ Users in the Human Resources OU have restricted access to cmd.exe 
▪ A user in Human Resources will be restricted on working hours 

 

For the first limitation we will be using a GPO. Select: 

 

Tools → group Policy Management 

 

 

 

Right click on the targeted OU (Human Resources) and select: 

 

Create a GPO in this domain and link it here 

 



We have got to create a new GPO named prevent access to the cmd. 

 

 

 

The GPO is now created. Now we have to edit what it will be doing.  

In the same interface go now to Group Policy Objects and expand it. 

 

Right Click [prevent access to the cmd] → Edit… 

 

 

 

Expand to: 

 

User Configuration → Policies → Administrative Templates → System 

 

From there we have to enable the installed GPO Prevent Access to the command 
prompt.  

 

 

 



Select the GPO and enable it 

 

 

 

We can check that the GPO is linked and enabled to our Human Resources OU 
by checking our GPO name. 

 

 

 

Since regular users are restricted from logging in the DC, we will check later in our 
Windows 10 machine joined to the domain that HR users can’t access cmd. 



The second limitation is to restrict a user’s logon hours.  

Select the user in Users and Computers. Select the user’s properties. 

 

 

 

Go to Account → Logon Hours 

 

 

 

We selected here a range of hours.  

Now it’s time to update our GPO. We will use the following command line: 

 

 



6) Computer Objects 

 

Since computers are also parts of Active Directory, we will join a machine to our 
domain as an object. 

Notice that it can also be part of an OU, helping the mapping of resources to 
different sections in an organization. 

In the next chapter we will install a Windows 10 VM machine that will be joined to 
our domain.  

 

 

Windows 10 Setup 

 

1) Network Settings 

 

The machine is already installed.  

We can get an IP from the DHCP server, or manually, it won’t change anything as 
long as our machine is not a server.  

Also, we must add the DNS of our domain controller, which is it’s IP, in order to 
detect the DC at the domain joining part (next sub chapter). 

To do so, select: 

 

WinKey+R → ncpa.cpl → Ethernet0 → Properties → IPv4 

 

 



The preferred DNS server will be the IP of the DC, and the second one will be the 
DNS of Google 8.8.8.8, we could choose also Cloudflare with 1.1.1.1 or 1.1.0.0 
depending on your preferences.  

 

2) Connectivity Check 

 

Let’s ping the DC to make sure that both machine can communicate 

 

 

 

Next, we must execute a nslookup command to make sure our DNS is ready to 
resolve bentech.com 

 

 

 

Our machine is ready to be joined to the DC since the bentech.com domain can 
be resolved on a DNS request. 

 

 

 3) Domain Joining 

 

In order to join our machine to the domain we must reach Access work or school. 



 

 

Select Connect 

Now we want to join a local Active Directory domain (Below, in Alternate Actions). 

 

 

 

Type the domain name (bentech.com) 

 

 



Administrators username and password is required. Login and wait. 

Now we can run ipconfig and make sure our machine is part of the domain. 

 

 

 

 

4) Security Measures 

 

We want to make sure our GPO is enabled and our user can connect at allowed 
hours. Let us open a cmd as the HR user and see what happens 

 

 



Great. Our cmd has been disabled.  

But especially in this case we should be careful with the GPO effectiveness.  

Some bypasses exist to get the command to run. 

Here are some examples. 

 

The first one involve running from the following command: 

 

WinKey+R → cmd /c whoami && cmd /k 

 

 

 

As we can see, the command prompt is disabled but the command is still 
running.  

The GPO cannot stop our command to run.  

A recent phishing attack has been observed with a fake captcha leading users to 
run commands under the WinKey+R utility. Read more about it. 

We can understand from there that GPO restrictions aren’t enough sometimes 
against advanced techniques.  

 

 

 

 

 

 

https://thehackernews.com/2025/01/beware-fake-captcha-campaign-spreads.html


Conclusions 

 

As a Network & System Administrator, I wanted to make sure that every step could 
be reproduced, for myself and anyone willing to setup from 0 an infrastructure, for 
testing or training purposes.  

It was a great experience as it is my first project and footprint for my next goal, 
jumping into the world of Cyber Security.  

Thanks to anyone who has been supporting me, especially for my mentor and 
brother, Ruben.  

 

 

 


