Active Directory Creation and Administration

Tutorial Number: 02

01 - Domain and Forest Creation

What is Active Directory (AD)?

Active Directory (AD) is a service that helps you manage users, computers, and resources in a centralized
way in a network domain.

What is AD DS (Active Directory Domain Services)?

= AD DS is the Windows Server role that enables you to run Active Directory.
= |Installing AD DS is just the first step — it does not yet configure AD.

It only installs the tools (like dcpromo.exe) needed to promote the server to become a Domain Controller.

Windows Server 2022

Active Directory Services are
installed on this Windows Server
2022, and it functions as the
domain controller.
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LAB: Install and Configure AD on Windows Server 2022
» Goal: Create a new forest and promote this server to the first domain controller.
v Step 1: Install AD DS Role

e Open Server Manager
e C(lick Add Roles and Features
e Select:
o Role-based or feature-based installation
o Select your local server
e Under Server Roles = Check Active Directory Domain Services
e Click Next until Install




This installs the AD tools, not AD itself yet.
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Select the installation type. You can install roles and features on a runni
machine, or on an offline virtual hard disk (VHD).

) Role-based or feature-based installation ‘/
Configure a single server by adding roles, role services, and features.

Remote Desktop Services installation
Install required role services for Virtual Desktop Infrastructure (VDI)
or session-based desktop deployment.

Select a virtual hard disk

Server Pool

®): Select a server from the server pool
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Select a server or a virtual hard disk on which to install roles and features.
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Select one or more roles to install on the selected server.
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AD DS Snap-Ins and Command-Line Tools




v Step 2: Promote the Server to Domain Controller

After AD DS is installed, you’ll see a yellow exclamation ! in Server Manager. Click “Promote this server to a
domain controller”
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1. Deployment Type: Create a New Forest

Since this is your first domain controller, you must create a new forest.

A forest is the topmost structure in AD — it contains one or more domains that trust each other
and share a schema.

2. Root Domain Name

You are asked to enter a fully qualified domain name (FQDN) like: corp.example.com
It’s recommended to use a domain you own publicly, like example.com.

Why choose a publicly owned domain?
v Prevents conflicts if your network connects to the internet or external services

v" Avoids name resolution issues with non-routable domains like .local
v" You can get SSL certificates, DNS records, email routing easier

Avoid made-up domains like company . local, especially with cloud integration.
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3.

Forest and Domain Functional Level

You must choose the lowest version of Windows Server you want to support.

Forest Functional Level: Applies to the entire forest
Domain Functional Level: Applies to the domain

Domain Controller Capabilities

DNS Server

o Yes—needed unless you already have a DNS setup
Global Catalog

o Yes —this DC will host full copy of AD
Read-only DC

o No —you need writable DC for first domain controller

Directory Services Restore Mode (DSRM) Password

Set a strong password here.
This is used when booting into DSRM mode to restore AD during disaster recovery.

This account is local to the server only, not a domain user.

6.

NetBIOS Domain Name

NetBIOS is an older naming system (used in legacy systems).

Windows will automatically suggest a NetBIOS name based on your root domain.
o E.g., corp.example.com - NetBIOS: CORP

You can change it if needed, but usually the default is fine.
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i Active Directory Domain Services Configuration Wizard - 0 X
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eview Options §. Windows Server 2022 domain controllers have a default for the security setting named
“Allow cryptography algorithms compatible with Windows NT 4.0° that prevents weaker o
=
Prerequisites Check cryptography algorithms when establishing security channel sessions em DONS

Prerequisites need to be validated before Active Directory Domain Services is installed on this
computer
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For more information about this setting, see Knowledge Base article 942564 (nttp://
go.microsoft.com/fwlink/?Linkld=104751).

A delegation for this DNS server cannot be created because the authoritative parent
zone cannot be found or it does not run Windows DNS server. If you are integrating
with an existing DNS infrastructure, you should manually create a delegation to this
DNS server in the parent zone to ensure reliable name resolution from outside the
domain "win.mrmick.in". Otherwise, no action is required.

}\ If you click Install, the server automatically reboots at the end of the promotion operation.
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What is a Forest in Active Directory?

A Forest is the topmost container in Active Directory.

It’s like a whole company or organization.
A forest can contain one or more domains.
All domains in a forest trust each other automatically.

All domains in a forest share the same schema and global catalog.

Forest = Security boundary + Logical container for domains.\

Example:

Imagine a company called TechWorld Inc.
They have multiple departments in different countries.

They might set up:
Forest Name: techworld.com

Domains under this forest:

us.techworld.com (for USA)

Events Events
Services Services
Performance Performance
BPA results BPA results
ﬂ £ Type here to search -
FOREST
mrmick.in
ACTIVE DIRECTORY
|
[ | |
i, S— i — i S—
Domain Users Computers

india.techworld.com (for India)

uk.techworld.com (for UK)

All domains are part of the same forest, share information, and trust each other.




What is a Domain in Active Directory?

A Domain is a group of objects (users, computers, printers, etc.) that are managed by the same security
policies.
e It’s like a department or branch within the organization. FOREST
e Domains are used to organize and secure network resources. U
e Each domain has:
o Its own Domain Controller(s) IACT'VE D;RECTORY I

o A unique name (e.g., sales.techworld.com) %] % %1
o Its own Group Policies
o

. . childl.mrmick.in child2.mrmick.in child3.mrmnick.in
Its own authentication

Domain = Unit inside a forest that holds users, computers, and resources.

02 Active Directory Management Tools

1. Active Directory Administrative Center (ADAC)

Tool to manage users, groups, OUs, GPOs, and advanced features in a modern interface.
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a. Dynamic Access Control (DAC)

i.  DAC allows file/folder access based not only on users but also user claims, device claims,
and resource properties.
ii. Example: “Give access to HR files only to users in HR department AND using domain-joined

laptops.”
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b. Enable Recycle Bin

i.  Allows recovery of deleted users, OUs, groups, etc. directly from the console.
ii. Must be enabled per forest.
iii.  Once enabled, you can right-click - Restore deleted objects (before tombstone period
ends).

Example Use Case:
Accidentally deleted a user account? Restore it in 1 click from Recycle Bin in ADAC.

< Active Directory Administ

B Active Directory... ¢ win (local) (13 Tasks

Dorm.ae Modifed  25/06/2025 0049

Enable Recycle Bin Confirmation X
I Are you sure you want to perform this action? Once Recycle B Active Directory.. ¢ win (local) (14)
Bin has been enabled, it cannot be disabled. |

Name - escription |

T
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2. Active Directory Domains and Trusts
Used to manage domain relationships and domain/forest functional levels.
a. Set Domain and Forest Functional Levels

i.  Define the lowest version of Windows Server allowed for DCs.
ii. Example: Set Windows Server 2022 level to enable new security features.

b. Create Trusts Between Domains/Forests

i.  Create trust relationships so users in one domain can access resources in another.
ii. Example:
I. Trust between sales.example.com and hr.example.com = cross-domain access.

Example Use Case:
You want users in Domain A to access files in Domain B - create a two-way trust.
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iy Active Directory Domains and Trusts
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3. Active Directory Module for Windows PowerShell

It is a PowerShell extension that adds AD-specific cmdlets for scripting and automation.
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4. Active Directory Sites and Services
Used to manage replication between domain controllers (DCs) across different physical locations (sites).

a. Replication

i.  AD replication is the process of copying data between domain controllers to keep them
updated.
ii.  If you have multiple offices, you create sites to represent them.
iii.  Replication between DCs in the same site = fast
iv.  Replication between different sites = scheduled (to save bandwidth)

b. Components:

i.  Sites = Physical locations (e.g., New York, London)
ii.  Site Links = Define how sites talk to each other
iii. Bridgehead Servers = Handle inter-site replication

Example Use Case:
You have DCs in India and UK. You want AD to replicate every 3 hours between them — configure this in
Sites and Services.
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5. Active Directory Users and Computers (ADUC)
The most common and basic tool to manage users, groups, OUs, and computers.
a. Key Features:

i. Create/modify users
ii. Reset passwords
iii.  Move objects between OUs
iv.  Create security groups
v.  Delegate control
vi.  Set Group Memberships




Example Use Case:
HR requests creation of 5 new user accounts — do it via ADUC.
Reset a user’s password or disable a leaving employee’s account.
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03 - Adding Second Domain Controller OR Child Domain

Why Add a Second Domain Controller?

Adding a second DC to your domain provides:
e Redundancy: If the first DC goes down, users can still log in and authenticate.
e Load Balancing: Authentication requests are split between DCs, improving performance.
e Replication: Both DCs share AD data — changes in one are replicated to the other.

Lab Setup Example

e First DCis: Server-01 (DC01) - Already a Domain Controller for domain: mrmick.in
e Now you want to make Server-02 a second Domain Controller in the same domain.




4+ Step-by-Step Guide to Add a Second Domain Controller
v’ Step 1: Set Correct DNS on Server-02 (DC02)
e On Server-02 (DC02), go to:

o Control Panel > Network Adapter Settings > IPv4
o Set Preferred DNS = IP of Server 01 (your first DC— DC01)

Why?
H
Because Server-02 needs to contact Server-01 to find domain info and join the domain.
& [1] internet Protocol Version 4 (TCP/IPv4) Properties
*[ # 5 Control Panel Network and Internet » Network Connections d v Coneral
General Networking You can get IP settings assigned automaticaly if your network supports
Organize v Disable this network device Diagnose this connection Rename this ca this capabiity. Otherwise, you need to ask your network admnstrator
Connection Comnect using for the appropriate IP settings.
- Ethernet - Ethernet 2
1Pv4 Connectivit
*E rrmick A ! N @ Red Hat WtIO Ethemet Adapter ") Cbtan an [P address automatically
&7 Red Hat VirtlO Ethernet Adapte & Red Hat VirtiO Ethernet pa 1Pv6 Connectivity
Mice Statei ® Use the folowng [P address
D Duration Ths comnecton uses the folowng tems [P address: €9 am—
Speec: ¥ B3 Cliert for Microscét Networks Subret mask 255 .255.254. 0
v g A o f
Detals.. B 4 1 te and Prrter Shavingfor Mos 1| petaust gatewar 6 em—
¥ 4 intemet Protocol Version 4 (TCP/IPvd D
[ 4 Microsoft Network Adapter Multiplexol .
Activity M 4 Microsoft LLDP Protocol Drver @) Use the folowng DNS server addresses.
W 4 intemet Protocol Version 6§ (TCP/IPVE Preferred O - N
- eferred ONS server: 205 ME— . 148
Alternate DNS server
Bytes Install
Descrption [vaicate setbr
L J 95 Upon ext
Transmission Control Protocol/intemet Protoy G Mvencsd
) Propertes wide area retwork protocol that provides co
across dverse nterconnected networks
1 item selecte Cancel

v Step 2: Join Server-02 (DC02) to the Domain (In tutorial this has been skipped)

e Right-click This PC > Properties > Rename this PC (advanced)
e C(Click Change and join domain: mrmick.in
e Reboot after successful domain join.

v’ Step 3: Install Active Directory Domain Services Role
e On Server-02 (DC02):
o Open Server Manager
o Click Add Roles and Features
o Select Active Directory Domain Services
o Click Next > Next > Install
[ This has been showed above, check the steps to install Active Directory Domain Services ]

v Step 4: Promote Server-02 to Domain Controller

e After install finishes, click Promote this server to a domain controller

e Choose:
o Add a domain controller to an existing domain
e Enter:

o Domain: mrmick.in
o Credentials: Use Domain Admin account from Server-01
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v’ Step 5: Choose Domain Controller Options

e DNS Server (Keep checked)

e Global Catalog (GC) (Keep checked)

e Read-only domain controller (RODC) (Leave unchecked for full DC)
e Set DSRM password (Directory Services Restore Mode password)

What Happens Now?

o Server02 becomes another DC for mrmick.in
e |t starts replicating AD data with Server-01 (DCO01)
e Both DCs can handle:

o User logins

o Group Policy

o DNS queries (if DNS role is installed)

Real-World Example

Imagine your head office is in Delhi, and branch in Mumbai.

You already have DC in Delhi. You set up a second DC in Mumbai (connected via VPN).

Now users in Mumbai authenticate locally, not over slow WAN — and if Delhi DC fails, Mumbai still runs
smoothly.




04 - Joining AD from a workstation

What Is Joining a Workstation to AD?

Joining a workstation (e.g. Windows 10/11 PC) to Active Directory allows:
e Centralized login using domain credentials

e Applying Group Policies

e Easier device and user management from the domain controller

Before You Start

Make sure:

Requirement

PC is on the same network/subnet as the Domain

Controller

PC’'s DNS server is set to the Domain Controller's IP

(e.g. 192.168.1.10 )

You have Domain Admin credentials (e.g.

admin@corp.local )

Why?

So they can talk to each other

So it can find the domain

Required to join machines to domain

Steps to Join a Workstation to AD

a. Step 1: Set DNS on Workstation

i.  Go to Control Panel > Network and Sharing Center

ii.  Click your network > Properties > IPv4
iii.  Set Preferred DNS to IP of Domain Controller (e.g., 192.168.1.10)

iv.  Click OK
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P address: 185 . 58 .194. 90
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_
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b. Step 2:Join the Domain

i.  Right-click This PC > Properties
ii.  Click Advanced system settings > Computer Name tab

iii.  Click Change
iv.  In Member of, select:
v' Domain, and enter: corp.local (or your domain name)
v.  Click OK
vi.  Enter Domain Admin credentials when prompted

e

.
Server Manager * Local Server - ® Manage  Tools

BN OCOPERTIES Computer Name/Domain Changes b4
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WORKGROUP
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Behind the scenes:

e The PC sends a request to the DC
e DC authenticates the credentials
e DC creates a computer object in AD

How to Verify in Active Directory

On Domain Controller:
1. Open Server Manager > Tools > Active Directory Users and Computers
2. Click on Computers container (left side panel)
3. You will see the workstation name listed there




05 - File Sharing and Drive Mapping

Part 1: Creating and Sharing a Folder

You want to share a folder from a server (e.g., Domain Controller or File Server) with domain users.

Steps to Share a Folder:
1. Create afolder, e.g.,
C:\SharedData

2. Right-click > Properties > Sharing tab

Option 1: Basic Sharing (Share Button)
a) Click Share

b) Add users or groups (e.g., HRGroup, Domain Users)

c) Set permissions (Read / Read-Write)

d) Click Share and then Done
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Choose people on your network to share with
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Option 2: Advanced Sharing
a) Click Advanced Sharing
b) Check: ¢/ "Share this folder"
c) Set Share Name (e.g., HRShare)
d) Set Limit number of users if needed
e) Click Permissions

Default has Everyone = Read
Remove Everyone group to avoid giving access to all users in the domain — it's not secure.

What is "Caching" in Advanced Sharing?
e Caching allows offline access to shared files
e If enabled, users can open/edit files without being connected, and files will sync when reconnected
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Part 2: Security Tab — NTFS Permissions

Go to:

e Right-click folder > Properties > Security Tab
What You Do Here:

e Set actual permissions on the file system

e These are more detailed and secure

Steps:
1. Click Edit
2. Remove or modify CREATOR OWNER if needed
3. Click Add to add users or groups (e.g., rameez)
4. Set Permissions:




KD ore e view

3 — - —m
- [ ] & Cu B = x -17 | New tem . s Ove 4 setect an
- Copy path 1 Lasy access = at Select none
Mnte Guick Copy Paste Move Copy Delete Rename  New Propenties ¢
access (] Peste shortan to~ o~ - tolaer - o T invert setection
Cuptosrd Organize New Open Setect
€ T % > ThaPC » Local Disk (C))

- o

Type Sae

Date modtied
# Quick access
o Desktop * 5 . 3 ™ Seiwct the cbedt type
T . - rogram Filey . Users. Groups, or Bt socurty pancpals | | Ctect Typws
Program Fiet |

- Seoun

8 Documents Gt | Sl Soouens oo Viions | i v =
= — Chyect name: € \ShamdData ok
- Puctures - 0 = c

b\‘mdow‘ l Growp or user rames
BB This PC l Group or user names

AR SYSTEM
@b Network a SR SYSTEM a

Ao
SR Advrustraorn (MBEMICK Admwrsstrand

Select Users, Computers, Service Accounts, or Groups x

P !

e == o=~

Fut Permssions for SYSTEM ANow Deervy

Modty il cortrol [~} - A

Head § exmcute Modty [ %] (]

L fokser corteres Read & execine (=] ()

Nad List fokder corteres =] (]

wao Fead =] o .
;-(’vuoo‘ Denreno e of advanced settnge Ao mced

ox Cancel Aok
ox Cancel Apoly
Permissions for SharedData X

Security

Object name:  C:\SharedData

Group or user names:

$2 SYSTEM
& Administrator

& MR MICK fameez@mmick in)

Pemissions for MR MICK
Full control
Modify
Read & execute
List folder contents
Read

@ Important Concept: Share vs. NTFS Permissions

Type Where Controls
Share Permissions Sharing tab Who can access folder over the network
NTFS Permissions Security tab Who can access folder locally or via network

{®) Most restrictive permission wins

If:

= “Share permission = Full Control”

| » “NTFS = Read
— User gets Read only”




Checking Access: "Effective Access"

Go to Security Tab > Advanced
Click Effective Access

Select a user or group

Click View effective access

PwNPE

Add tems

Add tems.

v =
T ” - iew effective acces
24 ot Effective access Permission Access limited by

Modly v X Full cenero Fie Permasions

od b esecuts v

: <« erse f execute f
2 fokder corters v
el v D | 2 foldes ata
o Read attrbutes A

This shows exactly what permissions that user has, considering both Share and NTFS.

File Sharing Using Server Manager

Instead of right-clicking a folder, you can use Server Manager > File and Storage Services for a more
structured and scalable way to manage shared folders.

Steps to Create a Shared Folder
Step 1: Open Server Manager
1. Open Server Manager

2. Click on File and Storage Services > Shares
3. On the top-right, click Tasks > New Share

$8 Share Profile Types (Options You See)

Option Purpose

SMB Share - Quick Basic, simple sharing

SMB Share - Advanced Adds more controls like quotas, file screening via FSRM
SMB Share - Applications For use with apps like Hyper-V or SQL (handles large files

& metadata better)

NFS Share - Quick/Advanced For Linux/Unix/Mac systems to connect to your Windows

shares




Step-by-Step: Create SMB Share — Quick

1. Choose Profile

a. Select: SMB Share - Quick (simple folder sharing)
2. Select Share Location

a. Type or browse custom folder path

Example: C:\ProjectData

@ *  Server Manager * File and Storage Services *

SHARES VOLUME
I Servers AR 1 shares | 3 total TASKS W o share is selectec
i Volumes i . | . -
=_ daecd . New Share Wizard - [m] x
| [ Disks
iji Storage Pools
o Select the serve ;‘[-1.'( ~ o
4 DCO1(3)
NETLOGON
- Server:
Work Folders SharedData
Server Name Status Cluster Role Owner Node
SYSVOL

DCo1 Online Not Clustered

Share location:
Select by volume:
Volume Free Space Capacity File System
c 646GB 789GB NTFS

The location of the file share will be a new folder in the \Shares directory on the selected

lume,
® Type a custom path: -

C:\ProjectData Browse...

< Previous | Next > Cancel

3. Configure Share Settings

Enable Access-Based Enumeration
e Only shows the files/folders a user is allowed to access
e Hides other files/folders from unauthorized users

Example:
User A only has access to Folder A — they won’t even see Folder B in the same share

Allow Caching of Share
e Allows offline access
e Users can work with files while disconnected, and changes sync back when reconnected

Example:
A laptop user goes out of office, edits a file offline - once they return and connect, changes sync

Encrypt data access
e Secures data while transferring over network
e Helps protect against sniffing/hacking




Example:

If user accesses share over Wi-Fi or public LAN, data is encrypted during transfer.

SH

Share

e

4 DCO1(3)
NETLOGON
SharedData

SYSVOL

IARES
shares

VOLUME
TASKS = No share is

fia New Share Wizard

Configure share settings

[¥] Enable access-based enumeration

Access-based enumeration displays only the files and folders that a user has permissions to
access. If a user does not have Read (or equivalent) p ons for a folder, Wind: hides the
folder from the user’s view.

[¥] Allow caching of share
Caching makes the contents of the share available to offline users. If the BranchCache for
Network Files role service is installed, you can enable BranchCache on the share.
Enable BranchCache on the file share
BranchCache enables computers in a branch office to cache files downloaded from this
share, and then allows the files to be securely available to other computers in the branch.
[¥] Encrypt data access
When enabled, remote file access to this share will be encrypted. This secures the data against
unauthorized access while the data is transferred to and from the share. If this box is checked
and grayed out, an administrator has turned on encryption for the entire server.

<Pr¢vious| Next > I “reate | | Cancel

4. Customize Permissions

Click Customize permissions, then:

e Go to Permissions tab (same as NTFS Security tab)
Add Domain Users group

Remove "Everyone" (to avoid open access)

[ )
e Give them Modify or Read access
[ )
[ )

On Share tab, also remove Everyone and give Full Control to desired group

Servers

il

G ——

ver Manager

Permissians to ace

Type

Allow
Allow
Alkow
Allow

Share permissons

Folder permasony

Princ|
CREA
suiLl
Buwl
BuLt
NT A

Name

Owner

* File and Starage Ser vic

Permussons

For additional inf

Permission entri¢

Type
Allew
Allow
Allow
Allow
Allow

EEERER

Customize pern D

Pl
sv
Ac
us
us
(<}

l

Disable inheri

[[) Replace all chi

Select User, Computer, Service Account, or Group x
Principal:

Seloct tha oboct typo
Alow User, Group, o Bk 4n securty prcpal Obyect Types..
Applies to: This folder, suble From this location
ek in Locatiors
Lrter the object name 10 asect (o:qmes)

MR MICK yamen @mmch inl] g Check Names

Basic permissions

Advanced

Add a condition to limit access. The principal will be granted the specified permissions only if conditions are met.

T Gy 10 e e

I q Principal: MR MICK (rameez@mrmick.in)  Select o principal G
« Previous | | Nex
Type: Allow -
-
Applies to: | This folder, subfolders and files -

Basic permissions:
IFull control =
2 Modity
(] Read & execute
4] List folder contents
2] Read
4 Write

(] Only apply these permissions to objects and/or containers within this container

Add a condition to limit access. The principal will be granted the specified permissions only if conditions are met

Add a condition




SHARES
WA 1 chares | 3 total

Name:

C:\ProjectData

Administrators (MR

O contrg
Owner:

pe‘,m'ss.D“s

To medify share permissions, select

missions to acc
missions, and, ¢

e permissions:

der permissions  Network location for this share: \\D|

/pe Princi  Permission entries:

Row CREA Type Principal
v sua B Alow Everyone
lliow BUILT

llow BuI1

llow INT Al

Customaze pern

ager * File and Storage Services

Permission Entry for ProjectData

Principat MR MICK (rameez@mmnick.in)

Type: Allow

Permussions:
FA Full Control
[A Change
FARead

Special permissions

Select a principa

-—

5. Create the Share

After Share Is Created

Access the Share from Client:

1. Open File Explorer

j=n SHARES

. [rtiteienrre
R New Share Wizard
Filte
Share

4 DC
NETLOG!

SharedD:
SYSVOL

Confirm selections

VOLUME

TASKS w |

Confirm that the following are the correct settings,

SHARE LOCATION
Server Dco1

role Not Clustered

Local path C\ProjectData

SHARE PROPERTIES
Share name ProjectData
SMB
Enabled
Enabled
Disabled
Enabled

< Previous

wlacbad

and then click Create.

| [ create ilj Cancel

2. Type the UNC path in address bar:
a. \\ServerName\ProjectData

v O

L] = | DCot
Home Share View
€« v ID oot —
# Quick access netlogon
B Desktop + -
‘ Downloads * sysvol
Z| Documents ¢ -~
&= Pictures *
8 This PC

¥ Network

ProjectData

SharedData

Search DC

0




OR

3. Map a Drive (optional):
a. Right-click This PC > Map Network Drive

b. Choose Drive Letter (e.g., Z:)
c. Enter path: \\ServerName\ProjectData
d. Check Reconnect at logon
e. Done!
= = | Dol
— 4 @ Network » DCO1 » v O
#* Quick access netlogon ProjectData SharedData
B Desktop - - Open
4 Downloads sysvol Open in new window
2! Documents < Pin to Quick access
& Pictures Restore previous versions
Pin to Start
3 This PC
Map network drive., =
¥ Network
Copy
Create shortcut
Properties
L Map Network Drive
What network folder would you like to map?
Specify the drive letter for the connection and the folder that you want to connect to:
Drive:
Folder: [ ThisPC = v
ideos
Example: \\server\share @ Network %
4] Reconnect at sign-in Devices and drives (1)
Connect using different credentials Local Disk (C:)
O ] < 2
Connect to a Web site that yvou can use to store your documents and pictures, LY 4.7 GB free of 4
Network locations (1)
ProjectData (\\DCO1) (Z:
rojectData )

Cancel

06 - Group Policy

Group Policy lets administrators control user and computer settings from a central place in Active Directory

(AD).

Example: You want to hide the Recycle Bin from all users' desktops — instead of going to each PC, you do it

once using Group Policy.

Tool Used: Group Policy Management Console (GPMC)
How to Open:
e Server Manager > Tools > Group Policy Management




Step-by-Step: Create a GPO to Hide Recycle Bin
Step 1: Create New Group Policy Object (GPO)
1. In Group Policy Management, right-click your domain name
Example: mycompany.local
2. Click: "Create a GPO in this domain and link it here"
3. Nameiit:

a. Hide Recycle Bin

This applies the policy at domain level (applies to all users). If you want it to apply only to some users,
move it to a specific OU (Organizational Unit).

Step 2: Edit the GPO

1. Right-click your GPO (Hide Recycle Bin) - Click Edit
2. You'll see two main sections:

7 Group Policy Editor: Two Main Sections

Section Applies To Example Settings

Computer Configuration Affects the machine, no matter who Set password policies, disable
logs in USB

User Configuration Affects the user, no matter which Hide Recycle Bin, lock Control
PC they log in from Panel

@ Since we want to hide the Recycle Bin for users, we use User Configuration

Step 3: Hide Recycle Bin

Navigate to:

User Configuration >
Administrative Templates >
Desktop >

Hide and disable all items on the desktop

Or more directly:

pPgsq

0

User Configuration >
Administrative Templates >
Desktop >

Remove Recycle Bin icon from desktop




1. Double-click: Remove Recycle Bin icon from desktop
2. Set to: Enabled
3. Click Apply > OK
Now this setting will remove Recycle Bin from desktop for users affected by this GPO.

Step 4: Delegation (Optional)

You can control who can edit or manage this GPO.

a. In GPMC, select the GPO

b. Go to Delegation tab

c. Click Add to give permission (Read / Edit / Full)

d. Use this to restrict junior admins from editing critical GPOs
Applying the GPO

Once created, the GPO will apply automatically:
e At next login for user-based settings
e Or during background refresh (every 90-120 mins by default)

To apply immediately, you can:
e Gotoaclient PC - open Command Prompt
e Run:
o gpupdate /force

Where Is the GPO Stored?

In GPMC, look under:
e Group Policy Objects = this contains the actual GPO "files"
e You can edit GPOs from here even if not yet linked

Example Lab Scenario
Goal: Hide Recycle Bin only for users in HR

e Create an Organizational Unit: HR

e Move HR users into that OU

e Create and link the Hide Recycle Bin GPO to the HR OU

e Edit GPO - User Config - Desktop - Remove Recycle Bin icon
e Apply GPO

e Login as HR user on client - Recycle Bin should be gone




07 - DNS Management

What is DNS in Windows Server?

e DNS = Domain Name System
e It translates names (like serverOl.company.com) to IP addresses (like 192.168.1.10) so computers
can talk to each other.

Why It Matters for AD?

Active Directory relies heavily on DNS:
e |t uses DNS to locate domain controllers, services, and replicate data.
e |f DNS is misconfigured, logins, Group Policy, and AD tools will fail.

Open DNS Manager
e Go to Server Manager > Tools > DNS

& derver Manager

Manage

Server Manager * Dashboard

Active Directory Administrative Center

Active Directory Domains and Trusts has
i WELCOME TO SERVER MANAGER )
B2 Dashboard Active Directory Module for Windows PowerShe

B Local Server Active Directory Sites and Senaces
W& Al Servers o e ) Active Directory Users and Computers
i ADDs SOTHIGHNE S 1Ual SETVE ADSI Edit
& DNs QUICK START TSR

A Computer Management
igr to — Add roles and features =
B§ File and Storage Services P Defragment and Optimize Drives

Add other servers to manaae Disk Cleanup E]

S=
WHAT'S NEW B \
Event Viewer

4 Default Zones Created with AD

When you install Active Directory Domain Services (ADDS) and promote to Domain Controller, Windows
automatically sets up DNS and creates two zones:

1. Forward Lookup Zone (company.local)
a. Translates name = IP
b. Example record: serverOl.company.local — 192.168.1.10

Server Manager * Dashboard

%, DNS Manager - m] X
I&8 Dashboard File Action View Help
0 Local Server o | nmXE HEHem d 8
!: All Servers Name Type Data Timestam
I§! ADDS v @ b msdcs
a =t + [ | Forward Lookup Zones 1
= DNS . j_swtes
| _msdes.mrmick.in j o

R File and Storage Services b | mrmickin j‘ ;

Reverse Lookup Zone -udp

Trust Points jDomamDn;Zonts

Conditional Forwarders ijEStDnszones

[ |(same as parent folder) Start of Autherity (SOA) [77], dc01.mrmick.in,, hos...  static
ﬂfsame as parent folder) Name Server (NS) dc02.mrmick.in, static
ﬂ (same as parent folder) Name Server (NS) de01.mrmick.in. static
ﬂ(same as parent folder) Host (A) Goumi 1 7/14/2025
ﬂ (same as parent folder) Host (A) 200M) 43 7/18/2025

— i dc0l Host (A) 209 148 static
E_IDCDE Host (A) 69— static

This is the working/production zone.




2. _msdcs.company.local
a. _msdcs = Microsoft Domain Controller Services
b. Contains records required for AD replication and locating domain controllers
c. Includes:
i. SRV records for services like LDAP, Kerberos
ii. GUID-based entries for each DC

It is automatically replicated to other DNS servers when they are also domain controllers.

=, DNS Manager = O X
File Action View Help
o) R XEc= HE &
= DNS . Name Type Data Timestam
v 5 DCO01 jdc
3 v Forward Lookup Zones jdomams
— _msdcs.mrmick.in
mrmick.in jgc
Reverse Lookup Zones :pdc ) ) )
Trust Points E_l(same as parent folder) Start of Authority (SOA) [21], dcO1.mrmick.in., hos... static
Condticnal Fonaaitess ﬂ(same as parent folder) Name Server (NS) dc01l.mrmick.in. static
E_I(same as parent folder) Name Server (NS) dc02.mrmick.in. static
E_I1ec9d4bb-cb3c-4ac3-346e-... Alias (CNAME) dc02.mrmick.in. 7/21/2025
E_|92469206-8&77-41f9-aS;e-b... Alias (CNAME) dc0l.mmmickin, e 7/18/2025

Creating a New Zone

Right-click Forward Lookup Zones > New Zone
You'll choose between:

1. Primary Zone
a. Main writable copy
b. Stored locally on the server
c. Most commonly used for Active Directory

Example: You create dev.company.local for development servers

2. Secondary Zone
a. Read-only copy of another DNS zone
b. Gets data from a primary zone via zone transfer
c. Used for redundancy and load balancing

Example: A second server in another office holds a copy of company.local as a secondary zone

3. Stub Zone
a. Holds only minimal info: NS (Name Server), SOA (Start of Authority), and A records for
another zone
b. Used for faster lookups across different DNS namespaces

Example: You have sales.company.local and want your server to redirect queries there without holding full
records




#+ Reverse Lookup Zone

e Does the opposite of forward lookup
e Translates IP = name

How to Create:

1. Right-click Reverse Lookup Zones > New Zone
Choose Primary Zone
3. Enter Network ID (based on subnet)
a. Example: If subnet is 192.168.1.0/24, enter 192.168.1
4. Now DNS can answer:
a. 192.168.1.10 — server0l.company.local

N

Used in security audits, logging, and troubleshooting

Lab Scenario

Goal: Create a reverse lookup zone for your AD subnet

1. Open DNS Manager
2. Right-click Reverse Lookup Zones > New Zone

3. Choose:
a. Zone Type: Primary
b. Replication Scope: To all DNS servers in AD forest

c. Network ID: 192.168.1
d. Finish
4. Now your DNS can resolve IP = Name

=, DNS Manager

File Action View Help

e 2@ EG= HmM § &
et EENS Name Type
v § ban E—I(sameas parent folder) Start of Authority (SOA)
v Forward LDOkuP_Zo?es E—|(same as parent folder) Name Server (NS)
| _msdcs.mrmick.in
- mrmick.in
v Reverse Lookup Zones
——p - 13.23.209.in-addr.arp
Trust Points

| Conditional Forwarders

Data
[1], dcO1.mrmick.in., host...
dc0l.mrmick.in,

Timestam

static
static




08 - DHCP Installation

What is DHCP?

DHCP (Dynamic Host Configuration Protocol) automatically assigns:

e |P address
e Subnet mask
e Default gateway
e DNS server
...to devices in a network.

So you don’t need to set IP manually on each client PC.
Step-by-Step: DHCP in Windows Server
v’ Step 1: Install DHCP Role

e Go to: Server Manager > Add Roles and Features
e Choose: DHCP Server
e Complete the wizard and Install
e Afterinstall, open:
o Tools >DHCP

f& Add Roles and Features leardl

= O

~ POy R e o DESTINATION SERVER
LK] T'! INstallation selecticC o DCO1.mrmick.in
o s s To install the following roles, role services, or features on selected server, click Install
nstaliation Type [[] Restart the destination server automatically if required
Server Selection Optional features (such as administration tools) might be displayed on this page because they have

their check boxes

DHCP Server

_ Remote Server Administration Tools
Role Administration Tools
DHCP Server Tools

< Previous

been selected automatically. If you do not want to install these optional features, click Previous to clear

|’ Install ‘I’ Cancel




v’ Step 2: Authorize DHCP Server

Before the server can hand out IPs, it must be authorized in Active Directory.

e In DHCP Console, right-click your server name
e Click Authorize
e Wait a few seconds; it should show a green check mark

Server Manager * Dashboard

m File Action View Help
e 2@ XEcz HE B2

& Local| - §
% DHCP — et
I'i-i AD D = |p:;"" Add/Remove Bindings... dc01.mrmick.in &
~ 2 Authori More Actions »
18 DHCH B 1P uihonze ‘—
& DNS Backup...
- Restore...
N§ Filea
All Tasks >
View >
Delete
Refresh
Export List...
Properties
Help
Displays Help for the current selection. __ility
v’ Step 3: Create a New IPv4 Scope
e Expand: DHCP > IPv4
e Right-click IPv4 > New Scope
e Follow the wizard:
Field Example

Scope Name

Start IP

End IP

Subnet Mask

Lease Duration

Router (Default Gateway)

DNS Server

Office Network

192.168.1.100

192.168.1.200

255.255.255.0

8 days

192.168.1.1

192.168.1.10 (your DC)

Once created, it’s ready to assign IP addresses to clients.




Reservation

v Reservation is used to always assign the same IP to a specific device based on its MAC address.
v’ Useful for printers, servers, or any device that should always get the same IP.

How to Create:
e Right-click on the Reservations folder under your scope
e Click New Reservation
e Fill:
o Reservation Name
o IP Address (pick from inside the range or outside)
o MAC Address (can be found using ipconfig /all on client)

Server Options
e Server Options are global settings (apply to all scopes on that DHCP server).

You can set:
e DNS Server IP
e Default Gateway
e Domain Name
e WINS Server (if used)

How to Configure:
e Right-click Server Options under IPv4
e Click Configure Options
e Check required options like:
o 003 Router
o 006 DNS Server
o 015 DNS Domain Name

You can also set these on a per-scope basis if needed.
Important Notes

You can’t have two DHCP servers active in same network unless they are in failover mode.
e Otherwise, Windows DHCP will shut down the second server to avoid IP conflicts.

Example Lab Scenario
Goal: Set up a DHCP server that assigns IPs to client PCs from 192.168.10.100-192.168.10.200.

e Install DHCP Role on Domain Controller
e Authorize DHCP
e Create scope named OfficeNetwork
e Setrange: 192.168.10.100 to 192.168.10.200
e Add router: 192.168.10.1
e Add DNS: 192.168.10.10
e Create reservation for printer (MAC: A0O-B1-C2-D3-E4-F5) = Assign IP: 192.168.10.150
e Onclient PC: Set to Obtain IP automatically
e Check IP using:
o ipconfig /all




